Obsahuje buňka text? (kombinace funkce KDYŽ a HLEDAT)

Tento článek je určen pokročilejším uživatelům Excelu a předpokládá základní znalost funkce KDYŽ.  Abychom zjistili, jestli je v buňce nějaký text nebo není, stačí ve funkci KDYŽ použít jednoduchou podmínku, jako kdybychom hledali buňku, která je rovna určitému číslu. Například pro hledání buňky s textem „jaro“, bychom napsali podmínku A1=“jaro“.

buňka je rovna textu jaro

Co když však chceme najít buňku, která jen určitý text obsahuje, ale může obsahovat i další znaky? Například, co když budeme hledat všechny buňky, které obsahují písmenko „o“? Potom budeme muset do podmínky vložit ještě další funkce.

Můžeme k tomu použít textovou funkci HLEDAT (anglicky SEARCH). Ta nám napíše, na jaké pozici v dané buňce zleva se nachází námi hledaný text. Vrátí nám tedy vždy číslo.

hledání pozice písmene o

Jak můžete vidět na obrázku, pokud funkce HLEDAT daný znak nenajde, vrátí chybu. Toho můžeme využít v podmínce pro testování, zda-li buňka daný znak obsahuje. Funkci HLEDAT pak stačí vložit do informační funkce JE.CHYBA (anglicky ISERR nebo ISERROR) a podmínka pro funkci KDYŽ je hotová.

Výsledný vzorec pro náš příklad vypadá následovně:

=KDYŽ(JE.CHYBA(HLEDAT(„o“;A1));“neobsahuje O“;“obsahuje O“)

buňka obsahuje písmeno o (kombinace KDYŽ, HLEDAT a JE.CHYBA)

6 komentářů u „Obsahuje buňka text? (kombinace funkce KDYŽ a HLEDAT)

  1. Honza Reagovat

    Díky za super návod, jak ale udělat, aby v případě pravdy, políčko zezelenalo nebo zčervenalo v případě nepravdy?

  2. Martina Říhová Reagovat

    Moc Vás zdravím, řeším vzorec pro situaci:
    Mám v excelu udělaný rezervační systém pro výuku lyžování. A abych nemusela počítat, kolik hodin je k dispozici, potřebovala bych vzorec – „když buňka obsahuje jednu hodnotu z vnořeného seznamu(což je jméno instruktora), zapiš číslo 1, pokud hodnotu z vnořeného seznamu neobsahuje, napiš 0. “ . Lámu si s tím hlavu…ale marně. Dokážete mi, prosím, pomoct, nebo můžete mě odkázat na nějaký web, kde se můžu dobrat odpovědi?

    Díky moc
    Marťa

  3. Karel Autor článkuReagovat

    to Honza: Stejná podmínka se dá místo do funkce KDYŽ vložit do podmíněného formátování (=>nové pravidlo=>určit buňky k formátování pomocí vzorce).

  4. Karel Autor článkuReagovat

    to Martina Říhová: Rád bych Vám poradil, ale nevím, co myslíte tím „když buňka obsahuje jednu hodnotu z vnořeného seznamu“. Co myslíte tím vnořeným seznamem?

  5. Martina Říhová Reagovat

    Dobrý den, ještě jednou. Buňka obsahuje akci buňky „ověřování dat“ -> „kritéria“ -> „seznam z rozsahu“. Možná v tom hledám něco zbytečně složitého 🙂 Nejlépe tak, bylo by možné Vám někam zaslat ukázku toho „příkladu“ ? Děkuji. Marťa

Napsat komentář: Karel Zrušit odpověď na komentář

Vaše e-mailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *