Obsahuje buňka text? (kombinace funkce KDYŽ a HLEDAT)

Tento článek je určen pokročilejším uživatelům Excelu a předpokládá základní znalost funkce KDYŽ.  Abychom zjistili, jestli je v buňce nějaký text nebo není, stačí ve funkci KDYŽ použít jednoduchou podmínku, jako kdybychom hledali buňku, která je rovna určitému číslu. Například pro hledání buňky s textem „jaro“, bychom napsali podmínku A1=“jaro“.

buňka je rovna textu jaro

Co když však chceme najít buňku, která jen určitý text obsahuje, ale může obsahovat i další znaky? Například, co když budeme hledat všechny buňky, které obsahují písmenko „o“? Potom budeme muset do podmínky vložit ještě další funkce.

Můžeme k tomu použít textovou funkci HLEDAT (anglicky SEARCH). Ta nám napíše, na jaké pozici v dané buňce zleva se nachází námi hledaný text. Vrátí nám tedy vždy číslo.

hledání pozice písmene o

Jak můžete vidět na obrázku, pokud funkce HLEDAT daný znak nenajde, vrátí chybu. Toho můžeme využít v podmínce pro testování, zda-li buňka daný znak obsahuje. Funkci HLEDAT pak stačí vložit do informační funkce JE.CHYBA (anglicky ISERR nebo ISERROR) a podmínka pro funkci KDYŽ je hotová.

Výsledný vzorec pro náš příklad vypadá následovně:

=KDYŽ(JE.CHYBA(HLEDAT(„o“;A1));“neobsahuje O“;“obsahuje O“)

buňka obsahuje písmeno o (kombinace KDYŽ, HLEDAT a JE.CHYBA)

Napsat komentář

Vaše e-mailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *