Funkce KDYŽ – více podmínek

Ve funkci KDYŽ můžeme nastavit jen jednu podmínku. Když platí, vloží nám jednu hodnotu, a když neplatí vloží nám hodnotu druhou. Tedy jedna podmínka a dvě možnosti, co nám funkce vrátí. Nic dalšího nastavit nemůžeme. Pokud bychom chtěli mít ve funkci KDYŽ více podmínek, museli bychom do vzorce vložit více funkcí KDYŽ. V nejnovějších verzích Excelu (2019 a 365) lze využít i funkce IFS. Pokud však máte starší verzi, tento článek je právě pro vás.

Vraťme se k příkladu z předchozího článku o jednoduché funkci KDYŽ. Chceme zjistit, jestli je číslo v buňce A1 kladné nebo záporné. Číslo však může být i 0 a ta není ani kladná, ani záporná. V takovém případě potřebujeme mít tři možnosti, které nám vzorec může vrátit, slova „kladné“, „záporné“ a „nula“.

Začít můžeme s tím, co jsme udělali v minulém článku, tedy s funkcí KDYŽ, která nám zjistí, jestli je číslo kladné.

první funkce KDYŽ

V případě, kdy číslo není větší než 0, zbývají nám ještě dvě možnosti – číslo je buď záporné nebo nula. Pro tyto dva případy použijeme další funkci KDYŽ, kterou vložíme do argumentu Ne předchozí funkce. Pro přehlednost jsem připravil následující diagram.

diagram znázorňující jak dostat do funkce KDYŽ více podmínek

Pro vložení druhé funkce KDYŽ můžete použít následující uživatelsky přívětivý postup:

  1. Klikněte do řádku vzorců první funkce KDYŽ.
  2. V bublině, která se pod řádkem vzorců objeví, klikněte ručičkou kurzoru na argument Ne.
    Tím se označí veškerý obsah tohoto argumentu (slovo „záporné“ včetně uvozovek).
bublina v řádku vzorců
  1. Vložte další funkci kliknutím do pole názvů na slovo KDYŽ.
vložení druhé funkce přes pole názvů

Teď už můžeme vyplňovat argumenty druhé funkce. Podmínka tedy bude A1<0. Pro Ano vložíme hodnotu „záporné“ a pro Ne slovo „nula“.

argumenty vnořené funkce KDYŽ

Po potvrzení tohoto okna je již vzorec hotov a vypadá následovně:

=KDYŽ(A1>0;“kladné“;KDYŽ(A1<0;“záporné“;“nula“))

Tento postup, jak dostat do funkce KDYŽ více podmínek, se dá nazvat vylučovací metodou a ve většině případů nám postačí: Pokud platí jedna podmínka, vlož jednu hodnotu, pokud platí druhá podmínka, vlož druhou hodnotu, …pokud neplatí ani jedna z předchozích podmínek vlož hodnotu, která je v argumentu Ne nejhlouběji vnořené funkce KDYŽ.

Sešit s příklady používanými ve videu můžete stáhnout zde.

Kdybychom chtěli mít ještě více podmínek a tím pádem i variant, které nám funkce může vrátit, opakovali bychom totéž pořád dokola. Stačilo by vždy do argumentu Ne nejhlouběji vnořené funkce KDYŽ vložit další funkci. Od Excelu 2007 je možné takto do sebe vnořit až 64 funkcí. Možností je tedy opravdu dostatek 😊

Napsat komentář

Vaše e-mailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *